Close

Results 1 to 9 of 9
  1. #1
    Join Date
    Feb 2013
    Posts
    28
    Rep Points
    55.5
    Mentioned
    0 Post(s)
    Rep Power
    0


    Yes Reputation No

    Strange Noise after Pure S2 install

    Got the PS2s installed and the car is making this strange noise when spooling and under full boost at WOT. The only way to describe it is as if its a teapot. Click here to enlarge

    Initially I thought it must be a boost leak but I've check all inlet/outlet couplers for leaks but didn't find any. No boost or power loss as far as I could tell, I will log a run sometime to make sure. I'm at a loss what the noise could be???

    Here is a video of what I am hearing. Any help would be greatly appreciated.


  2. #2
    Join Date
    Nov 2014
    Posts
    143
    Rep Points
    165.0
    Mentioned
    0 Post(s)
    Rep Power
    2


    Yes Reputation No
    Did you check your fmic couplers? Sounds like a big boost leak, a log would help determine if you possibly have a boost leak or not

  3. #3
    Join Date
    Feb 2013
    Posts
    28
    Rep Points
    55.5
    Mentioned
    0 Post(s)
    Rep Power
    0



    Yes Reputation No
    It's been raining here the last few days so I haven't been able to do a log. The installer checked for boost leak prior to delivery, I had a faulty boost solenoid and wasn't making boost at all. Since fixing that, I've checked the passenger side couplers (inlet/outlet on the turbos) and fmic, they were tight.

    Also checked the charge pipe to TB, those were good too. Only one left is the driver side FMIC couple which I will need to find time to check.

    What I notice is that the noise comes in around 8+ psi to full boost. Goes away when I let off, comes back when I get back into boost. So it sounds like boost related for sure. First I wasn't getting boost, now I am and the strange noise. SMH.

  4. #4
    Join Date
    Dec 2009
    Posts
    2,185
    Rep Points
    1,625.1
    Mentioned
    14 Post(s)
    Rep Power
    17


    Yes Reputation No
    You're making full boost, right?

  5. #5
    Join Date
    Feb 2013
    Posts
    28
    Rep Points
    55.5
    Mentioned
    0 Post(s)
    Rep Power
    0



    Yes Reputation No
    I got 15-18 lbs base on the gauge hijack on JB4 but I haven't logged to be sure. Butt Dyno feels like it spoke and pulls stronger then stock turbos but it could be a placebo?

  6. #6
    Join Date
    Nov 2014
    Posts
    143
    Rep Points
    165.0
    Mentioned
    0 Post(s)
    Rep Power
    2


    Yes Reputation No
    You're gonna make more power with the same boost levels as oem turbos with bigger turbos

  7. #7
    Join Date
    Jan 2010
    Location
    SoCal
    Posts
    137,661
    Rep Points
    40,995.1
    Mentioned
    2418 Post(s)
    Rep Power
    410


    Yes Reputation No
    Click here to enlarge Originally Posted by Evo2xi Click here to enlarge
    I got 15-18 lbs base on the gauge hijack on JB4 but I haven't logged to be sure. Butt Dyno feels like it spoke and pulls stronger then stock turbos but it could be a placebo?
    Probably placebo. Honestly, hard to diagnose.

  8. #8
    Join Date
    Feb 2013
    Posts
    28
    Rep Points
    55.5
    Mentioned
    0 Post(s)
    Rep Power
    0



    Yes Reputation No
    Yeah I just logged that it spikes to 17 and drops to 14-15. I'm not sure if its tampering or if it is a boost leak.

    pure1.csv

  9. #9
    Join Date
    Jan 2010
    Location
    SoCal
    Posts
    137,661
    Rep Points
    40,995.1
    Mentioned
    2418 Post(s)
    Rep Power
    410


    Yes Reputation No
    Click here to enlarge Originally Posted by Evo2xi Click here to enlarge
    I'm not sure if its tampering or if it is a boost leak.
    Tapering.

    That would be normal but someone needs to look at the log.

Posting Permissions

  • You may not post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
  •